BQE Knowledgebase



Updating Crystal Reports templates

Problem: User has a custom report or invoice that no longer works in the new version of BillQuick.

Cause: As technology advances, BillQuick uses the latest or updated versions of Crystal Reports engine. If your report was created in a version older than Crystal Reports 9.0, it must be upgraded to work with BillQuick 2003 or later version.

Solution: To create custom reports or upgrade previous version of BillQuick custom reports, you must use Crystal Reports 9 or later. After Crystal Reports is installed, you can specify in User Preferences-Folders screen where Crystal Reports Designer is located. A message displays if BillQuick cannot find the Crystal Reports program. Once the installation directory is set, you can open Crystal Reports by selecting Design/Edit Invoices, Reports from the Reports menu.

Using Crystal Reports, you can upgrade previous versions of Microsoft Access or SQL Server compatible BillQuick report templates to Crystal Reports version 9 or later. The steps mentioned below assume you are upgrading Microsoft Access compatible report templates; the same procedure applies to SQL Server compatible report templates. We strongly recommend that you back up the original copy of the report template before upgrading.

1. Open your report in Crystal Reports version 9 or later.

2. From the File menu, choose Save As to save the report with a different name.

3. Select Database and set the data source location. In the Set Data Source Location dialog, ‘Current Data Source’ list displays the database and tables currently used in the report. The main report is shown as the root node.

4. Browse to the OLE DB (ADO) folder. Click ‘Create New Connection’ under this folder to launch the OLE DB (ADO) Wizard.

5. Select Microsoft.JET.4.0.OLE DB Provider from the OLE DB Provider screen. Click ‘Next’ to navigate to the Connection Information screen.

6. Use the browse (. . .) button next to the Database Name to navigate to the BillQuick database you have upgraded to. When you find the database, double-click on it to select it.

7. Enter the database password in the ‘Jet Database Password Box’. By default, the password of your BillQuick 2009 database is ‘admin’.

8. Click Finish to save your changes and close the OLE DB (ADO) Wizard.

9. After establishing the connection with the BillQuick 2009 database, you can upgrade your report. Select the old database in the Current Data source list and the new database that you want to map the report to in the ‘Replace With’ list.

10. Click the ‘Save’ button to update the new data source information in the Current Data Source list. If the new data source is different from the one you're replacing, the ’Map Fields’ dialog appears which is used to link report fields to their corresponding database fields when changes are made to the structure of the database. The Map Fields process helps you to make sure your reports print with the current version of the active database.

11. In the Map Fields dialog, uncheck ‘Match Type’ checkbox. Select an Unmapped field from top left box and the same field in top right box. Make sure that you select the same database field in both the boxes and uncheck Match Type option. Click ‘Map’ button.

12. Repeat step 10 for all the unmapped fields. After mapping all the fields, click OK to exit the Map field dialog.

13. Click Close in the ‘Set Data Source Location’ dialog and exit.

14. Press F5 to refresh the report. If you get an error message regarding Boolean fields, replace every true value by -1 and false by 0 in Formula Workshop. Repeat this whenever you get this message. If there are no errors then your report is successfully upsized to Crystal 9 or later.

15. From File menu, choose ‘Save’.

16. If your report contains sub reports, select each of the sub report from the Current Data Source list in Set Data Source Location dialog and repeat the steps 9 to 14.

Note:
• If you get a message ‘Join Not Supported’, change the joins to ‘Left outer join’ in the Link Options window from Database/Data Expert/Links.

• If you get a message ‘Specify table required for any unmodified tables’, click Database/Data Expert. Remove the un-used tables from the ‘Selected Tables’ list and then keep the proper joins that were there earlier in the report or select the joins from similar BillQuick 2009 standard reports.

• Sometimes invoices do not show expenses. This is mostly with invoices that have sub reports. In this case, open the sub report in Crystal 9 or later. Select the Field Explorer from the View menu. Scroll to the Parameter Fields in the navigator window. Click + to expand the branch. Right click on Pm-Transaction Table-Transaction ID. Select Edit from the popup menu. In the Edit Parameter Field window, set the Value Type field to ‘string’.

• When converting non-billable expense entries to BillQuick 2009, the value of ‘amount’ is calculated and displayed unlike the earlier versions of BillQuick. However, the entry remains red to signify its non-billable property.

BQE offers Consulting Services to upsize your older custom reports and invoice templates to the latest version for a nominal fee. To contact our Report Customization Team, please call Sales at (888) 245-5669. Outside USA call +1 (310) 602-4020.


Related Articles

Attachments

No attachments were found.

Visitor Comments

Article Details

Last Updated
11th of May, 2018

Product
BillQuick, Web Suite

Would you like to...

Print this page  Print this page

Email this page  Email this page

Post a comment  Post a comment

 Subscribe me

Subscribe me  Add to favorites

Remove Highlighting Remove Highlighting

Edit this Article

Quick Edit

Export to PDF


User Opinions

No users have voted.

How would you rate this answer?




Thank you for rating this answer.

Continue